Xubuntu 11.10, Gimp 2.7.5 и обновление системы

Главная Форумы Использование Общие вопросы Xubuntu 11.10, Gimp 2.7.5 и обновление системы

В этой теме 4 ответа, 2 участника, последнее обновление  prokoudine 5 года/лет, 6 мес. назад.

Просмотр 5 сообщений - с 1 по 5 (из 5 всего)
  • Автор
    Сообщения
  • #923

    Egor
    Участник

    Поставил себе Gimp 2.7.5 отсюда https://launchpad.net/~matthaeus123/+archive/mrw-gimp-svn
    Для его установки требовались дополнительные репы:

    GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos

    deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

    deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main

    Ну, добавил я их, Gimp установил, но при обновлении системы выскочило сообщение что «пакеты из недостоверных источников»и обновление прекращается, хотя ключи я прописывал.
    Через «apt-get upgrade» система вроде обновляется, но затем в окне обновлений всё по-старому. Куча пакетов требующих установки.

    В чём глюк? В репозиториях или в самой системе?

    #1733

    prokoudine
    Хранитель

    Глюк в совете по добавлению репозиториев.

    Правильно это делается командой apt-add-repository, которая правильно импортирует ключи.

    1. Вынесите строчки из sources.list
    2. Запустите sudo apt-get update
    3. Добавьте репозитории через sudo apt-add-repository (ppa:gnome3-team/gnome3, ppa:ricotz/testing)
    4. Снова sudo apt-get update.

    И дальше устанавливайте гимп.

    #1734

    Egor
    Участник

    Спасибо! Вроде началось обновление. Вечером приду — посмотрю (зg интернет не шибко шустрый).
    И ведь про sudo apt-add-repository шпаргалка прямо на ланчпаде есть, а я её прозевал.

    #1740

    Egor
    Участник

    Вообщем, обновление системы прошло успешно, почти. Маленький глюк остался.
    Из репозитория ricotz/testing висят необновленными два пакета, причём их даже выбрать нельзя для обновления.

    Clutter is an Open GL based interactive canvas library, designed for creating fast, mainly 2D single window applications such as media box UIs, presentations, kiosk style applications and so on.
    libclutter-gtk-1.0.0
    Установленная версия: 1.0.2-0ubuntu2
    Доступная версия: 1.1.3+git20120223.092ee700-0ubuntu1~11.10~ricotz0

    libclutter-1.0-0
    Установленная версия: 1.8.0-1~svn1
    Доступная версия: 1.9.13+git20120229.c4658817-0ubuntu1~11.10~ricotz0

    Это обновление поставляется источником, не поддерживающим списки изменений.

    Они сильно нужны, или может не стоит и заморачиваться?
    И, ещё вопрос, когда выйдет стабильная версия GIMP`а надо будет другие репозитории прописывать или можно этими пользоваться?

    #1743

    prokoudine
    Хранитель

    Egor написал:
    Они сильно нужны, или может не стоит и заморачиваться?

    Можно не заморачиваться.

    Egor написал:
    И, ещё вопрос, когда выйдет стабильная версия GIMP`а надо будет другие репозитории прописывать или можно этими пользоваться?

    А вот это наверняка никто не скажет.

Просмотр 5 сообщений - с 1 по 5 (из 5 всего)

Для ответа в этой теме необходимо авторизоваться.